?

Log in

No account? Create an account

Previous Entry | Next Entry


Инструкция по сопоставлению n систем.

1)Отчеты из TS,лист Trades,поля "дата" и "профит по трейду" копируется в эксель
2)Дата+время разделяются с помощью "текст по столбцам",время удаляется
3)По каждой паре столбцов дата+профит делается сводная таблица.В "строках" дата,в Значениях сумма по полю профит(в новом экселе это делается через
Данные-Создать запрос:Из таблицы>в редакторе запросов Группировать по>Операция:сумма,Столбец:NetProfit>>закрыть и загрузить.
4)Начальная дата+автозаполнение рабочими днями до последней даты создает столбец всех дат
5)функция =ВПР(J1;G:H;2;ЛОЖЬ) где J1-все даты,GH-столбцы с датой и профитом,2-номер столбца с профитом в отобранной таблице,ЛОЖЬ-выбираются только точно соответствующие значения.
6)Фильтр H/Д ,удаляем
7)Сумма,скользящая сумма,совокупный график.

Comments

( 11 комментариев — Оставить комментарий )
t_trade
6 фев, 2012 16:10 (UTC)
"стандартное правило" - по опыту или из книжек?
pratrader
6 фев, 2012 17:52 (UTC)
Кто-то написал, да стер "Профит не может складываться :) Он усредняется."

Профит может складываться.
santiaga_09
6 фев, 2012 17:19 (UTC)
Очень полезная штука, тоже намедни такую сделал.
Еще сделал отдельно графу с объемом позиции для каждого алгоритма. Теперь вручную меняя объем, вижу общий результат по доходности и ДД всего комплекса посделочно.

Вот вопрос: насколько реальный ДД у всего комплекса может быть больше максимального исторического? Я вот сейчас беру коэффициент запаса ~1,7. Но вот в сомнениях.. не мало ли?
pratrader
6 фев, 2012 17:54 (UTC)
Это зависит от того с какой целью берешь и какие цели в трейдинге.
santiaga_09
6 фев, 2012 18:53 (UTC)
С целью оценить нормальный риск возможных просадок портфеля. Т.е. до какого уровня еще нормально, а после какого уже нет..
Цели долгосрочные, R/R по году не ниже 1/3 + более 75% прибыльных месяцев.
(Удалённый комментарий)
pratrader
6 фев, 2012 20:03 (UTC)
Конкретно в том участке две лучше чем любая одна.
Как правило две лучше одной,три лучше двух.
Но да,иногда,бывает так,что в некоторой совокупности все льют,но дд при этом все равно меньше чем по некоторым компонентам совокупности.
trader_notes
20 фев, 2012 08:23 (UTC)
А с какой вероятностью дд сложаться? Должен быть какой то интервал доверительный для такой гипотезы. Не пробовал искать?
anatomisteg
16 июл, 2012 06:27 (UTC)
а почему бы не скомпилировать множество систем в одну систему? подскажите пожалуйста что такое скользящая сумма?)
"системы 1+2" график построен по половинному объему входа в сделку?

Edited at 2012-07-26 10:59 (UTC)
pratrader
26 июл, 2012 19:08 (UTC)
можно и скомпилировать,какая разница-то?
( 11 комментариев — Оставить комментарий )

Метки

Разработано LiveJournal.com
Designed by Tiffany Chow